LaTeX Translation - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Create Maple Worksheets : Export a Maple Worksheet : worksheet/managing/exporttolatex

Translation of Maple Worksheets to LaTeX

  

The Export as LaTeX facility translates a Maple worksheet or document into a LaTeX document.

  

For instructions on how to export a Maple worksheet as LaTeX, see Export as LaTeX.

  

The generated LaTeX document contains a number of usepackage calls corresponding to packages distributed with modern LaTeX distributions.

 

Description

The Maple LaTeX Document Structure

Description

Tips for File > Export > LaTeX are found in the Tips section of the latex help page. The following is a description of what happens when you export the worksheet/document:

• 

Displayed mathematics including both Maple input and output, is translated into LaTeX, using automatic line-breaking (for details, see latex). Equations labels, appearing in the output, possibly used in the input and in the text are translated as such, and their occurrence in text and input is hyperlinked to the corresponding output.

  

The translation of mathematical expressions performed precisely respects the form and color you see on the screen with very few exceptions (e.g. the blue in Maple's output is not translated). You can change some of the default behaviors using latex:-Settings.

• 

Code Edit Regions are translated using the listings package.

• 

Text is exported to LaTeX text using UTF-8 encoding.

• 

Text formatting such as bold, underline, superscripts, subscripts are exported to LaTeX equivalents.

• 

Hidden content is not exported. So, in the worksheet, before exporting, you can remove all or selectively some of Maple's input, while keeping all of Maple's output and corresponding equation labels, by respectively using the menu items View > Show/Hide Contents or Edit > Delete Element. This is particularly useful to produce LaTeX mathematical documents that entirely or partially hide their computer algebra origin.

• 

Images are exported to external image files and links to these files are included in the LaTeX document.

• 

Sections and subsections are mapped to LaTeX sections and subsections as required.

  

Note that sections which are collapsed at time of export will not appear in the generated LaTeX.

• 

Sketches are not exported.

• 

Maple character styles are mapped directly onto LaTeX macro calls.

• 

Maple paragraph styles are mapped onto LaTeX environments.

• 

Maple spreadsheets are converted to LaTeX tables.

Processing

• 

The Maple worksheet or document is processed from beginning to end and written to a file. All the mathematics, in the input, output and possibly inlined in the text, is translated using the latex command.

• 

Images and plots are exported to separate files in appropriate formats and links to those files are inserted in the LaTeX document.

• 

The resulting TEX file is a LaTeX document that can be processed with standard LaTeX applications.

• 

In the initial document, Maple uses a standard LaTeX style known as article.

The Maple LaTeX Document Structure

  

Some page numbering options specified in the Maple worksheet are applied to the LaTeX document and can be set using the menu item Insert > Header Footer. These include the following:

• 

Page numbering on or off

• 

Starting number

• 

Numbering of the first page

• 

Style of the page numbers

Page Layout

  

The horizontal and vertical positions of the page numbers are not exported. They are determined by LaTeX.

  

Page break objects are translated to the corresponding page break object.

  

The overall page layout of the document is decided by the document class specified at the top of the file. This is done by including a line of the following form:

\documentclass{article}

  

Several standard LaTeX styles are available, such as report, book, and article, each giving a slightly different page layout. Many mathematics publishers provide their own styles.

  

The document body (the actual content of the Maple worksheet) appears between the lines.

\begin{document}

  

and

\end{document}

Macros

  

Several TeX macros appear between the class definition and the document body (an area of the LaTeX document called the document preamble.) These macros define (or redefine) other macros used in the document body.

  

The macro definitions specific to Maple documents are defined as a macro package called maple. This is included in your document by the line:

\usepackage{maple}

  

The Maple-defined styles used in your document are defined within the maple.sty file found in the ../etc/.. directory of your Maple installation. That file includes the LaTeX macros

\DefineParaStyle{maplegroup}

\DefineParaStyle{Author}

\DefineParaStyle{Title}

\DefineParaStyle{subtitle}

\DefineParaStyle{Heading 1}

\DefineParaStyle{Heading 2}

\DefineParaStyle{Heading 3}

\DefineParaStyle{Heading 4}

\DefineCharStyle{Maple Input}

\DefineCharStyle{Maple Normal}

\DefineCharStyle{Maple List Item}

\DefineParaStyle{Maple Bullet Item}

\DefineParaStyle{Maple Dash Item}

\DefineParaStyle{Maple Ordered List 1}

\DefineParaStyle{Maple Ordered List 2}

\DefineParaStyle{Maple Ordered List 3}

\DefineParaStyle{Maple Ordered List 4}

\DefineParaStyle{Maple Ordered List 5}

\DefineParaStyle{Diagnostic}

\DefineParaStyle{Error}

\DefineParaStyle{Warning}

\DefineCharStyle{2D Math}

\DefineCharStyle{Help Heading}

\DefineCharStyle{FixedWidth}

\DefineCharStyle{endFixedWidth}

  

The default Maple styles each have a predefined LaTeX definition in maple.sty. For information, see Printing and Viewing Maple LaTeX Documents.

See Also

Export as LaTeX

Hide Content

How latex Formats Functions

latex

latex:-Settings

Printing and Viewing Maple LaTeX Documents

Tips for Export As LaTeX