maplets/plotter/2D - Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : maplets/plotter/2D

Two-Dimensional Plot Window Help

  

Using the 2-D plot window, you can display and manipulate a Maple plot data structure. The 2-D plot window is invoked by using the plotsetup(maplet) command, followed by a plot command. For example,

plotsetup(maplet):

plot(cos(x/2) + sin(2*x), x = 0..4*Pi);

  

The plot window contains menus that allow you to can change attributes of the plot structure. For more information about the plot structure, see the plot and plot/options help pages.

 

File Menu

Style Menu

Axes Menu

Projection Menu

Help Menu

File Menu

  

The File menu allows you to export the plot and close the plot window.

  

To create a file containing the 2-D plot:

1. 

From the File menu, select Export.

2. 

Select a file type: Postscript, GIF, or JPEG. The other listed file types are only available for 3-D plots.

3. 

Specify the output filename.

  

The file is saved in the root folder of your Maple install. For example, in Windows, this is by default C:\\Program Files\\Maple.

  

To close the plot window:

• 

From the File menu, select Exit.

Style Menu

  

From the Style menu, you can select one of three plot styles.

• 

Polygon with Outline fills the regions and displays grid lines. This is the default style.

• 

Polygon fills the regions, but does not display grid lines.

• 

Line draws the plot as lines.

• 

Point shows only the points calculated.

• 

Point and Line shows the points as well as a line through the points.

  

For most 2-D plots, Patch functions the same as Line, except for density plots or filled contour plots, which use polygons. The style can also be specified using the style option with the plot command. For details, see plot/options.

  

Using the Style menu, you can select values for other options.

• 

Line Width controls the thickness of line plots and polygon borders.

• 

Line Style specifies the pattern used when drawing line segments.

• 

Point style specifies how the points are drawn when you select the Point style, for example, Diamond.

Axes Menu

  

Using the Axes menu, you can choose how the axes are drawn.

• 

Boxed places the axes along the bounding box of the image and draws the bounding box.

• 

Framed draws the axes along the bounding box, but does not draw the box.

• 

Normal causes the axes to intersect at zero values when possible. Otherwise, the axes intersect at a minimum value on any axis.

Projection Menu

  

Using the Projection menu, you can select one of the two scaling styles.

• 

Unconstrained scales the surface to fit the window. This is the default behavior.

• 

Constrained shows the true scale of the surface. The scaling can also be specified using the scaling option to the plot command.

Help Menu

  

The Help menu opens this help page.

See Also

plot

plot/device

plot/options

plots[contourplot]

plots[densityplot]